Card issuer: NBG elevated error rate
Incident Report for EveryPay S.A.
Resolved
This incident has been resolved.
Posted Apr 08, 2022 - 22:10 EEST
Update
We are continuing to investigate this issue.
Posted Apr 08, 2022 - 21:41 EEST
Investigating
We are currently investigating this issue.
Posted Apr 08, 2022 - 21:23 EEST
This incident affected: Third Parties.