Issuer: National Bank of Greece
Incident Report for EveryPay S.A.
Resolved
issue has been resolved
Posted May 20, 2022 - 11:08 EEST
Update
We are continuing to investigate this issue.
Posted May 20, 2022 - 11:07 EEST
Investigating
We are currently seeing an increased decline rate by cards Issued from NBG
Posted May 20, 2022 - 10:44 EEST
This incident affected: Third Parties.