Card issuer: Alpha Bank elevated error rate
Incident Report for EveryPay S.A.
Resolved
This incident has been resolved.
Posted Nov 05, 2022 - 08:23 EET
Investigating
We are currently investigating this issue.
Posted Nov 05, 2022 - 07:28 EET
This incident affected: Third Parties.