Card issuer: Eurobank elevated error rate
Incident Report for EveryPay S.A.
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 11:14 EET
Investigating
We are currently investigating this issue.
Posted Nov 16, 2022 - 09:57 EET
This incident affected: Third Parties.