Apple Pay: Increased number of failed payments

Incident Report for EveryPay S.A.

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 17:00 EET

Investigating

We are currently investigating this issue.
Posted Jan 29, 2025 - 13:02 EET
This incident affected: EveryPay Production (Payform - Checkout).