Issue with POS transactions

Incident Report for EveryPay S.A.

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 16:59 EEST

Investigating

We are currently investigating this issue.
Posted Jul 06, 2026 - 16:15 EEST