Card Issuer: Alpha elevated error rate
Incident Report for EveryPay S.A.
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 12:29 EET
Update
We are continuing to investigate this issue.
Posted Mar 17, 2023 - 12:28 EET
Investigating
We are currently investigating this issue.
Posted Mar 17, 2023 - 10:55 EET
This incident affected: Third Parties.