Card Payment Scheme: Mastercard is experiencing technical issues, resulting to an unprocessed number of e-Commerce transactions.
Incident Report for EveryPay S.A.
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 11:31 EET
Investigating
We are currently investigating this issue.
Posted Nov 30, 2022 - 10:26 EET
This incident affected: Third Parties.